Topics

Quisk + Linux + WSJT-X

Dave Barnes
 

(1) Some housekeeping (Assumes Debian/Ubuntu).....

  (a) If not already installed, you will need to install "pavucontrol" - "sudo apt install pavucontrol"

  (b) You will want to setup the ALSA Loopback device.  Edit /etc/modules (use your favorite editor) - "sudo gedit /etc/modules" - and add a line with "snd-aloop".

  (c) Now ALSA loopback will be available at each boot.  To start loopback manually without rebooting - "sudo modprobe snd-aloop"

(2) You will need to install some support libraries:

"sudo apt install python-wxgtk3.0 fftw3 python3-dev python2.7-dev fftw3-dev libasound2-dev libpulse-dev portaudio19-dev"

(There may be others for later versions. Check the Quisk website below.)

(3) It is best to get the latest Quisk from "james.ahlstrom.name/quisk"  Download the .tar.gz file of the latest Quisk version. 

  (a) Unpack the source - "tar -zxf quisk-4.1.3.tar.gz"

  (b) "cd quisk-4.1.3"

  (c) "make"

  (d) If no errors then Quisk has been compiled properly.

(4) Download the quisk_conf_proficio.py from this forum.  Save as ".quisk_conf.py" in your home directory.

(5) Tell PulseAudio not to manage the Proficio audio: using "pavucontrol" -


(6) Run Quisk - "python ~/quisk-4.1.3/quisk.py"

The "DGT-U" mode routes audio out the "Digital Output" stream.

(7) Setup PulseAudio to route to the correct sound devices: use "pavucontrol" again

The Digital Output is available to be routed to another program via Loopback.  The Radio Output should be routed to your speakers.

(8) Install WSJT-X 1.7.0 - start WSJT-X

  (a)  Configure the Radio:


To check, press the Test CAT button.

  (b)  Set up audio: (Here is where we use the loopback device)

(9) Setup Microphone and digital audio through Loopback with "pavucontrol"

QtPulseAudio stream is input to WSJT-X

(finish) Make QSOs !

=================================

A similar process can be followed for FL-DIGI or QSSTV.  The key is connecting the inputs and outputs via "pavucontrol".

Jens / DH1AKY
 

Thanks Dave,

works very well. I managed it to receive and send in SSB using this description but the devices in WSJT-x are scambled on my machine. Received no audio in WSJT-x. I will go on with that trial&error tomorrow. This evening it was fascinating to listen on 40 and 80 als well.

73, Jens / DH1AKY

Jens / DH1AKY
 

Works well now, my mistake. Got great results on 40 and 80 within one hour (see picture). Antenna Windom 42m long 5 m above ground only.


Ron / W4MMP
 

Good, glad to hear.

Please let us know the mistake so other folks can learn.

73,
Ron / W4MMP
On 1/30/2017 5:53 PM, je_wa@... wrote:

Works well now, my mistake. Got great results on 40 and 80 within one hour (see picture). Antenna Windom 42m long 5 m above ground only.




--
Thank you for your support and business,
73,
The Omnia SDR Team,
Ron / W4MMP

Jens / DH1AKY
 

Hi Ron,

there are still two issues: 

1st the pavucontrol settings doesn't seems to be persistant on Linux Mint/Debian, so I have to do all the settings again and again.

2nd Today the communication in the setup was getting wrong, the Proficio doesn't transmit any tones. After some tries it receives on 20, but not at any other band. After reboot of proficio and restart of quisk everything works fine.

I will try to reproduce this situations.

BTW: The enclosure arrived today.

73 Jens / DH1AKY

 

Ron / W4MMP
 

Hi Jens,

Something to keep in mind (I am not sure if this relates to your issue(s).   When the Proficio is power cycled the default mode of frequency translation to emulate a Si570 oscillator.   If then the ExtIO_Proficio DLL is used (windows) the mode is set to Si5351 mode (the DLL sends a special operations code to the Proficio).   There is no method to set it back to Si570 mode without a power cycle.  I will update the ECN with this information.  The bottom line is that if ExtIO_Proficio.dll is used at anytime, a power cycle is required to set the Proficio back to the Si570 default.

73,
Ron / W4MMP
On 1/31/2017 3:50 PM, je_wa@... wrote:

Hi Ron,

there are still two issues: 

1st the pavucontrol settings doesn't seems to be persistant on Linux Mint/Debian, so I have to do all the settings again and again.

2nd Today the communication in the setup was getting wrong, the Proficio doesn't transmit any tones. After some tries it receives on 20, but not at any other band. After reboot of proficio and restart of quisk everything works fine.

I will try to reproduce this situations.

BTW: The enclosure arrived today.

73 Jens / DH1AKY

 



--
Thank you for your support and business,
73,
The Omnia SDR Team,
Ron / W4MMP

Dave Barnes
 

The pulseaudio connections do seem to be somewhat random.  I don't know how to make the settings persist.  Although, you can use the pulseaudio names in the .quisk_conf.py.  Those pulseaudio device names would be something like "pulse:alsa_input.platform-snd_aloop.0.analog-stereo".  You should be able to use an abbreviation, probably "pulse:alsa_input.platform-snd_aloop.0" or even "pulse:snd_aloop.0".  I have never been able to get things to work all of the time so I just use "pulse" and reset the sound connections with pavucontrol every reboot.


djb

Dave Barnes
 

You can get a list of the Linux/Pulseaudio inputs (sources) and outputs (sinks) like this -

Open a terminal and enter:

pacmd list-sources | grep name.*alsa

pacmd list-sinks | grep name.*alsa

Jens / DH1AKY
 

Thanks Dave,

there is also another issue concerning quisk/wsjt-x: If you change the band from 80 to 40 to 20, the mode isn't switched correctly to usb-digital. But I think that's a problem of the CAT/hamlib interface of wsjt-x (v1.7.0-devel).

Thanks & 73,

Jens / DH1AKY

Jens / DH1AKY
 
Edited

... most times the problem sits in front of the computer: in WSJT-X Settings you have to set the mode to USB, the screenshot above is wrong concerning this. If you set the mode correctly to the USB all is working fine even on the low bands.

Previous Topic Next Topic