Topics

Raspberry pi 3 Quisk

Charles Wood
 

Trying to get either the Basic or the Proficio (both eventually) running Quisk on a pi3

I know it has been done but I am having trouble getting it to work.

I need help with the configuration files.  I have a great grasp on the full installation, got a basic to work once... then didn't save it... now I cant get it going again.

I know their are standard peaberry config in the install and the proficio one is posted here... but what/how/where do these get modified and where are they placed. 

Thanks in advance

Charles

KC0QIZ

Dave Barnes
 

Put the desired Quisk config in the file ~/.quisk_conf.py 

That file will be a hidden file in your home directory.

-OR-

You can put the Basic and Proficio configs into separate files in your home directory - for example, quisk_conf_proficio.py and quisk_conf_basic.py - and start Quisk like this:

python ~/quisk-4.1.3/quisk.py -c ~/quisk_conf_proficio.py

-and-

python ~/quisk-4.1.3/quisk.py -c ~/quisk_conf_basic.py

73, djb

Jens / DH1AKY
 
Edited

Here is my quisk.conf I use on my Raspi 2. I use a thumb-style usb device for sound. Please use the names listed in brackets at command 'aplay -l' at the lines .

So if your device is listed as [Generic USB Audio Device] so you have to change the line 

name_of_sound_play = "alsa:Generic USB Audio Device"

like in my config file.


73 de Jens, DH1AKY

Charles Wood
 

Thanks everyone...

one question...

I am assuming the "home" directory is where quisk is located correct?


Charles Wood
 

ok, now I have audio with no control over the Omnia basic.

it tells me configuration file not found /hom/pi/.quisk_

Charles Wood
 

so the ~/.quisk_conf.py  is nowhere to be found to "put" the peaberry config into....


Charles Wood
 

I should have stated from the beginning... I know nothing about linux

Charles Wood
 

ok so now I have audio only working on Omnia and Proficio...

I set up the _conf_peaberry the same as Jens with exceptions of the sound cards... set them to my configuration...

I still have no control over the transceivers....

Dave Barnes
 

To control the radio you need to be allowed to access the USB devices.

Add udev rule for user to access USB (see Quisk docs)

Create a file in /etc/udev/rules.d called "80-local.rules" and copy the following line:

SUBSYSTEM=="usb", ATTR{idVendor}=="16c0" , ATTR{idProduct}=="05dc", MODE="0666", GROUP="dialout" 

Then reboot the rpi.

Note that the Basic/Peaberry uses  "si570_direct_control = True" and "channel_i = 0 / channel_q = 1" while the Proficio uses "si570_direct_control = False" and "channel_i = 1 / channel_q = 0"

You will probably want two separate config files and NO ~/.quisk_conf.py file. Your home directory is probably /home/pi on the rpi.  Shortcut to your home directory is the tilda character "~".

I don't have a Peaberry or a Basic so I can't confirm if those settings are still correct. 

djb

Ron / W4MMP
 

Hi Dave,

Not that I know much of anything about Quisk, but I have a question about the line:

"Note that the Basic/Peaberry uses  "si570_direct_control = True" and "channel_i = 0 / channel_q = 1" while the Proficio uses "si570_direct_control = False" and "channel_i = 1 / channel_q = 0""

Why is the Proficio different from the Basic/Peaberry?   The control interface is identical on all three rigs. 

73,
Ron / W4MMP
On 3/28/2017 23:36, Dave Barnes wrote:

To control the radio you need to be allowed to access the USB devices.

Add udev rule for user to access USB (see Quisk docs)

Create a file in /etc/udev/rules.d called "80-local.rules" and copy the following line:

SUBSYSTEM=="usb", ATTR{idVendor}=="16c0" , ATTR{idProduct}=="05dc", MODE="0666", GROUP="dialout" 

Then reboot the rpi.

Note that the Basic/Peaberry uses  "si570_direct_control = True" and "channel_i = 0 / channel_q = 1" while the Proficio uses "si570_direct_control = False" and "channel_i = 1 / channel_q = 0"

You will probably want two separate config files and NO ~/.quisk_conf.py file. Your home directory is probably /home/pi on the rpi.  Shortcut to your home directory is the tilda character "~".

I don't have a Peaberry or a Basic so I can't confirm if those settings are still correct. 

djb



--
Thank you for your support and business,
73,
The Omnia SDR,LLC Team,
Ron / W4MMP

Charles Wood
 

Thanks... but still no control....

Charles Wood
 

Ron,

I have tried it both ways and I cant seem to get it going....

frustrating knowing others have it working just fine..

I probably have something odd set that will be a DUH moment when it does work..

like I said I fired it right up first time I installed it and it hasn't worked since...

Ron / W4MMP
 

Hi Charles,

When you say, no control does that mean nothing?  No TX, no frequency control?   Have you tried a power cycle on the Proficio?   Keep in mind, if you used the ExtIO_Proficio.dll and did not power cycle the rig,  frequency control will not work. 

73,
Ron / W4MMP
On 3/28/2017 23:54, Charles Wood via Groups.Io wrote:

Ron,

I have tried it both ways and I cant seem to get it going....

frustrating knowing others have it working just fine..

I probably have something odd set that will be a DUH moment when it does work..

like I said I fired it right up first time I installed it and it hasn't worked since...



--
Thank you for your support and business,
73,
The Omnia SDR,LLC Team,
Ron / W4MMP

Ron / W4MMP
 

Let me clarify that.   If you use the ExtIO_Proficio.dll with HDSDR and then switch to another host application,  the Proficio needs power cycled so that it falls back to Si570 mode.  Si570 mode is required for all host applications (Windows or Linux) other than HDSDR. 

73,
Ron / W4MMP
On 3/28/2017 23:57, Ron / W4MMP via Groups.Io wrote:

Hi Charles,

When you say, no control does that mean nothing?  No TX, no frequency control?   Have you tried a power cycle on the Proficio?   Keep in mind, if you used the ExtIO_Proficio.dll and did not power cycle the rig,  frequency control will not work. 

73,
Ron / W4MMP
On 3/28/2017 23:54, Charles Wood via Groups.Io wrote:

Ron,

I have tried it both ways and I cant seem to get it going....

frustrating knowing others have it working just fine..

I probably have something odd set that will be a DUH moment when it does work..

like I said I fired it right up first time I installed it and it hasn't worked since...



--
Thank you for your support and business,
73,
The Omnia SDR,LLC Team,
Ron / W4MMP



--
Thank you for your support and business,
73,
The Omnia SDR,LLC Team,
Ron / W4MMP

Dave Barnes
 

After I posted that line, I realized that can't possibly be right.  The config file for the Peaberry included with Quisk has things set that way.  Was there a Peaberry version 1 that had different settings?

djb

Ron / W4MMP
 

Possibly.  I don't go back that far. 

73,
Ron / W4MMP
On 3/29/2017 00:30, Dave Barnes wrote:

After I posted that line, I realized that can't possibly be right.  The config file for the Peaberry included with Quisk has things set that way.  Was there a Peaberry version 1 that had different settings?

djb



--
Thank you for your support and business,
73,
The Omnia SDR,LLC Team,
Ron / W4MMP

Charles Wood
 

Ron,

Yes I meant no control as in freq change, band switching,,, etc

rebooting did nothing...

I only hear what the basic resorts to hearing when first powered on

Ron / W4MMP
 

Hi Charles,

I wish I could help, but time does not permit. 

Not to poor salt on the wound, but for folks following this thread,   this is why Omnia SDR has chosen HDSDR to be the SDR host application for build / testing purposes.   For the most part, it is easy to configure and it just works.  Trust me on this,  I have tried almost every host application available over the course of the last three years.  Almost without fail, I end up saying, "what? you've got to be kidding me" when it comes to attempting to configure them. 

73,
Ron / W4MMP
On 3/29/2017 10:51, Charles Wood via Groups.Io wrote:

Ron,

Yes I meant no control as in freq change, band switching,,, etc

rebooting did nothing...

I only hear what the basic resorts to hearing when first powered on



--
Thank you for your support and business,
73,
The Omnia SDR,LLC Team,
Ron / W4MMP

Charles Wood
 

I totally understand Ron...

I will get it eventually lol

Charles Wood
 

Got it!

I ignored the peaberry configs and just adjusted it until it works....

thanks for the assistance everyone

Charles

KC0QIZ

Previous Topic Next Topic