Topics

W6JHB: OSB and Quisk on RPi

James Bennett <w6jhb@...>
 

Anyone here been successful getting their OSB running with Quisk on a Raspberry Pi? I just finished (well, 99 percent finished) building a 60/40/30/20 Semi-DIY OSB. Works fine with HDSDR on Windows 8.1 except for not being able to use CW. I did manage one local QSO on 40 CW using Rocky on Windows 8.1 today. However, my goal is to use the OSB on my RPi2.

I currently have a SoftRock Ensemble RXTX that I use on my RPi2, occasionally with Quisk but most of the time in a 24-7 WSPR operation. This afternoon I unhooked the OSB from Windows, moved the USB cable over to my RPi2, rebooted it, and fired up Quisk, using the existing config file. No signals were seen on the Quisk display. I was hoping the existing config file would work as is, but looks like some changes are gonna be needed. The first thing needing a change will be the sampling rate, as my RXTX was using a Tascam US-125M external sound card at 48000 and the OSB runs 96000. Not sure what else I need to tweak.

Anyway, wondering if anyone else has gotten their OSB running on an RPi and/or with Quisk....???

Jim Bennett / W6JHB
Folsom, CA

James Bennett <w6jhb@...>
 

Forgot to mention - Quisk and the OSB are at least partially speaking the same dialect, as when I change bands on the Quisk panel, I can hear the relay in the OSB click, so that was a good sign. Also, when I keyed my CW paddle, the green LED on the OSB started flashing, so,it WAS going into transmit. However, monitoring the frequency that Quisk was set to via my Elecraft K3, no RF was going out to the antenna, nor did Quisk display any signals on the band.

Jim Bennett / W6JHB
Folsom, CA

On Feb 27, 2016, at 8:04 PM, James Bennett w6jhb@... [omniasdr] <omniasdr@...> wrote:

 

Anyone here been successful getting their OSB running with Quisk on a Raspberry Pi? I just finished (well, 99 percent finished) building a 60/40/30/20 Semi-DIY OSB. Works fine with HDSDR on Windows 8.1 except for not being able to use CW. I did manage one local QSO on 40 CW using Rocky on Windows 8.1 today. However, my goal is to use the OSB on my RPi2.

I currently have a SoftRock Ensemble RXTX that I use on my RPi2, occasionally with Quisk but most of the time in a 24-7 WSPR operation. This afternoon I unhooked the OSB from Windows, moved the USB cable over to my RPi2, rebooted it, and fired up Quisk, using the existing config file. No signals were seen on the Quisk display. I was hoping the existing config file would work as is, but looks like some changes are gonna be needed. The first thing needing a change will be the sampling rate, as my RXTX was using a Tascam US-125M external sound card at 48000 and the OSB runs 96000. Not sure what else I need to tweak.

Anyway, wondering if anyone else has gotten their OSB running on an RPi and/or with Quisk....???

Jim Bennett / W6JHB
Folsom, CA

Randy
 

Yeah, the sound card settings are not right.  As the old configuration is still trying to get data from the sound card used by the Softrock RXTX and not the Omnia's (Peaberry) audio devices.

Randy

P.S.  I've not tried to use Quisk or RPi with the Omnia yet.

Ron / W4MMP
 

Jim,

Attached are two files.  A sample quisk_conf.py and an instructions file.   I do not know if they work.  Another ham sent these to me and I have not found the time to try them on the RPi 2.
73
Ron / W4MMP
On 2/27/2016 23:08, James Bennett w6jhb@... [omniasdr] wrote:

 
Forgot to mention - Quisk and the OSB are at least partially speaking the same dialect, as when I change bands on the Quisk panel, I can hear the relay in the OSB click, so that was a good sign. Also, when I keyed my CW paddle, the green LED on the OSB started flashing, so,it WAS going into transmit. However, monitoring the frequency that Quisk was set to via my Elecraft K3, no RF was going out to the antenna, nor did Quisk display any signals on the band.

Jim Bennett / W6JHB
Folsom, CA

On Feb 27, 2016, at 8:04 PM, James Bennett w6jhb@... [omniasdr] <omniasdr@...> wrote:

 

Anyone here been successful getting their OSB running with Quisk on a Raspberry Pi? I just finished (well, 99 percent finished) building a 60/40/30/20 Semi-DIY OSB. Works fine with HDSDR on Windows 8.1 except for not being able to use CW. I did manage one local QSO on 40 CW using Rocky on Windows 8.1 today. However, my goal is to use the OSB on my RPi2.

I currently have a SoftRock Ensemble RXTX that I use on my RPi2, occasionally with Quisk but most of the time in a 24-7 WSPR operation. This afternoon I unhooked the OSB from Windows, moved the USB cable over to my RPi2, rebooted it, and fired up Quisk, using the existing config file. No signals were seen on the Quisk display. I was hoping the existing config file would work as is, but looks like some changes are gonna be needed. The first thing needing a change will be the sampling rate, as my RXTX was using a Tascam US-125M external sound card at 48000 and the OSB runs 96000. Not sure what else I need to tweak.

Anyway, wondering if anyone else has gotten their OSB running on an RPi and/or with Quisk....???

Jim Bennett / W6JHB
Folsom, CA